RSS

Instructiunea FOR

14 Feb

Exista trei instructiuni (structuri) repetitive folosite in toate limbajele:

  • instructiunea repetitiva cu test initial CAT TIMP (WHILE) (se foloseste cand numarul de repetitii este nedefinit)
  • instructiunea repetitiva cu test final REPETA-PANA CAND (DO WHILE sau REPEAT) (se foloseste cand numarul de repetitii este nedefinit)
  • instructiunea repetitiva cu un numar cunoscut de pasi PENTRU (FOR) (se foloseste cand numarul de repetitii este cunoscut – un numar fix de ori.)

Sintaxa:

  • FOR(initializare; test final; pasul urmator) instructiune;
  • for (i=A; i<=B; i++) {secventa de repetat}
  • for (i=1; i<=n; i++) {secventa de repetat}

Efect:

  • pentru fiecare valoare a contorului i intre expresia initiala si expresia finala se executa instructiunea;

Exemplufor (i=1; i<=n; i++) cout<<” Nu ma prinzi!”;

  • pentru fiecare valoarea a variabilei i, de la 1 la N, se afiseaza ” Nu ma prinzi!”; de N ori
  • daca secventa ce trebuie repetata contine mai multe instructiuni, acestea se vor grupa cu acolade

Observatii:

  • instructiunea este “ceruta” daca descrierea algorimului spune “de la valoarea X la valoarea Y”, “pentru primele X valori”, “de X ori”, …


 
2 Comments

Posted by on 14/02/2012 in C2_2 Limbajul C/C++

 

2 responses to “Instructiunea FOR

  1. ANDREI

    12/01/2016 at 09:18

    Salutari.Sunt in clasa a 10 a si ce-i drept nu ma prea pricep asa de mult la info,dar vr sa invat.Am gasit un exercitiu din variantele din 2009,mai precis din varianta 16 in care trb sa transform din algoritm in program
    Citeste n(nr natural nenul)
    {Pentru i<-1,n-1 executa
    Daca i%2=0 atunci
    Scrie '*'
    Pentru j<-i+1,n executa
    Scrie'*'
    }
    Am folosit acoladele ca la c++ pt ca nu stiam cum sa fac.Asa,problema mea este de e cand il tranaform in program si ajung la prima si cea de a doua instructiune for arata asa:
    For(i<1;i<=n;i++) respectiv
    For(j<1;i<=n;i++) la cea de a doua instructiune for
    Ceea ce ma nedumereste sa zic asa este de ce initializarea sau prima expresie din "for" este i<1?Sper sa mi se raspunda.Multumesc

     
  2. mchelariu71

    13/01/2016 at 13:26

    for(i=1; i<=n;i++) //adica , cu I de la 1 la N

     

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: